UploadedFileProcessor - problem

Aug 14, 2009 at 5:27 PM

Hi,

I set the UploadFileProcessor of my Uploader control to "MySolutionName.MyFileProcessor,MySolutionName", just like the example.

But I'm getting an error when I try to upload files on my app.

The progress goes until the end. I think it's can't access my custom processor.

The class implements the provided interface correctly. It does nothing, like the example, but it still does not work.

 

=/

Regards.

Coordinator
Aug 14, 2009 at 6:34 PM

If you have incorrectly specified the UploadedFileProcessorType, it should say "Error" as the status of the file, because it will throw an exception trying to create an instance of your class.  If it doesn't, something else must be going on...

Also, UploadedFileProcessorType is "[Fully qualified class name with namespaces],[Assembly Name]".

For example, if I have an assembly called Vci.dll, and in it I create a class in Namespace1.Namespace2 called MyClass, I would specify:

UploadedFileProcessorType="Namespace1.Namespace2.MyClass,Vci"

Hope that helps.

Aug 14, 2009 at 6:57 PM
Edited Aug 14, 2009 at 7:36 PM

I made a library called MyFileProcessor.dll, put a reference on my WebSite project (both are in same solution), then I wrote:

UploadedFileProcessorType="Namespace1.Namespace2.MyFileProcessor,MyFileProcessor"

I still get an error message.

Thanks.

 

EDIT: I removed the first Namespace. Now it calls: "ProjectNamespace.MyFileProcessor, MyFileProcessor"

'bout the error? The same.

Coordinator
Aug 14, 2009 at 9:52 PM

I would need more information to help you diagnose the problem at this point -- are you able to run the project in the debugger and get more information about the error?